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Preface
This textbook explains how to perform Finite Element Analysis using the Generative
Structural Analysis workbench in CATIA V5. CATIA is a three dimensional CAD/CAM/
CAE software developed by Dassault Systèms, France. This textbook is based on CATIA
V5 Release 21. Users of earlier releases can use this book with minor modifications.
It is assumed that readers of this textbook are familiar with creating parts and assemblies
in CATIA V5. However, any persons not familiar with CATIA V5 modeling and assembly but interested in FEA can learn through the step by step processes laid out in this
textbook, such as naming a part file, creating a 3D model for analysis or defining an FE
model. Each process is accompanied by illustrations.
Each chapter deals with a major topic in FEA and proceeds with an analysis procedure
using CATIA V5 Structural Analysis. At the end of each chapter the author explains the
meaning of the results and recommends additional topics to be considered.
Engineers and mechanical engineering students are highly recommended to read this textbook to increase their knowledge of FEA by using CATIA V5 Generative Structural
Analysis.
Topics covered in this textbook
- General concepts of FEA
- Singularity in static analysis
- Effects of fillets and stiffeners
- Bearing loads and reflective symmetry
- Rotational loads and cyclic symmetry
- Use of a coordinate system in defining boundary conditions and loads
- Using two dimensional and one dimensional elements
- Connections: Seam weld, rigid, bolt, pressure fit and contact
- Applying loads with enforced displacement
- Automatic mesh adaptation
- Using the temperature effect in static analysis
- Buckling and normal mode analysis
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chapter

Centrifugal Force
and Cyclic Symmetry

After completing this chapter you will
understand
- how to apply rotational velocity and/or acceleration
as force.
- the use of cyclic symmetry and how to apply its
boundary condition.
- how to use a virtual part to apply a boundary condition.

Ch 8: Centrifugal Force and Cyclic Symmetry

8.1 Introduction
A part that rotates with high speed can break due to centrifugal force. We can take into
account angular velocity and/or acceleration in linear static analysis by using Rotation
Force in the Loads toolbar.

If the model for analysis repeats its shape regularly rotating around an axis, it is called a
cyclic symmetry model. In this case, we can use only a portion of the model to obtain the
same results as using the full model. The theory is similar to the case of reflective symmetry. Note that we have to apply proper boundary conditions on the cut planes.
For the cyclic symmetry model, loads and restraints have to satisfy the cyclic symmetry
condition. Centrifugal force and pressure fit are typical examples of cyclic symmetry
loads.

Sample Chapter

The flywheel in Fig 8-1 repeats its shape rotating around an axis. It is under centrifugal
load and we will use only 1/8th of the full model. Time and resources for calculation decrease dramatically and we can obtain the same result as when using the full model.

Fig 8-1 Cyclic Symmetry Model

8.2 Create 3D Model
Create a Part
1. Run CATIA V5 and close all sessions by choosing File > Close in the menu bar.
2. Choose File > New and select Part from the New dialog box.
3. Type in the part name as flywheel_full.CATPart and press OK.
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Fig 8-2 Part Naming

Create Full Model
1. Create a sketch as shown in Fig 8-3 on the xy plane and Pad it by 15 mm along both
sides. Choose Mirrored extent option.
2. Save the part file in d:\catia_cae.

Sample Chapter

Fig 8-3 Creating a Part (Full Model)

Creating 1/8 Model
1. Choose File > Save As from the menu bar.
2. Name the new part as flywheel_1_8.CATPart.
We will analyze the 1/8 model first and then the full model.
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Create Reference Plane
1. Choose the Axis button from the Tools toolbar.
2. Press OK in the dialog box. Coordinate system is created at Global origin (0, 0, 0).

Sample Chapter
Fig 8-4 Creating Coordinate System

3. Choose the Plane button from the Reference Element toolbar.
4. Set the Plane Definition option. We will create a 45 deg inclined plane with respect to
the yz or zx plane.
45˚ inclined plane

Fig 8-5 Creating Plane
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Split the Model
1. Choose the Split button from the Surface-Based Features toolbar.
2. Split the part body with the 45 deg inclined plane as shown in Fig 8-6.
3. Save the file.

Sample Chapter
Fig 8-6 Creating 1/8 Model

8.3 Mesh Deﬁnition
Execute the GSA Workbench
1. Press the Start button in the menu bar and choose Analysis & Simulation > Generative Structural Analysis.

2. A warning message appears because we did not apply material for the part. Press OK in
the Warnings dialog box.
3. Select Static Analysis in the New Analysis Case dialog box and press OK.
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Fig 8-7 Invoking the GSA Workbench

Modify Mesh Definition
1. Double click on OCTREE Tetrahedron of Nodes and Elements in the Spec Tree and
set the Size and Sag as shown in Fig 8-8.

Sample Chapter
Fig 8-8 Modifying Mesh Option
Let’s display the mesh on the geometry. You can skip this step if you are sure about the
quality of the mesh.
2. Press mouse button 3(MB3) on Nodes and Elements in the Spec Tree and choose
Mesh Visualization.

3. Read the warning message and press OK.
4. Hide the mesh symbol in the model
5. Change the view mode to Shading with Edges.
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Fig 8-9 Mesh Visualization

8.4 Restraints and Loads
Boundary conditions and loads can be applied on 3D geometry such as faces, edges,
points and vertices, and the mesh has to be defined on the geometry.
Let’s define the symmetric boundary condition on the cut plane.

Sample Chapter

1. Move the mouse pointer on Links Manager.1 and press mouse button 3(MB3). Then
choose Hide/Show from the pop-up menu to show the 3D geometry.
2. Choose the Surface Slider button from the Restraints toolbar.
3. Select the plane cut by the zx plane and press OK in the dialog box.
Surface Slider restraints translation normal to the plane and frees other degrees of free-

dom. Note that there are no rotational degrees of freedom in the 3D element.

Fig 8-10 Applying Surface Slider Restraint
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You can apply Surface Slider restraint on the 45 deg slanted plane, but in this example
we will use the User-defined Restraint function to achieve the same effect. If we are
going to restrain the normal direction translation on the slanted plane with User-defined
Restraint, we have to define the coordinate system first.

Let’s define the coordinate system aligned to the inclined plane.
1. Expand Links Manager.1 in the Spec Tree.
2. Double click on flywheel_1_8 to invoke the Part Design workbench.
We cannot use the coordinate system that has been created to define the 45 deg inclined
plane because it is not in accordance with the normal direction of the plane.

Double Click
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Fig 8-11 Invoking the Part Design Workbench
3. Choose the Axis button from the Tools toolbar.
4. Show the existing coordinate system in the Spec Tree.
5. Select the origin of the coordinate system.
6. Select the edge on the plane to restrain as the X axis (

in Fig 8-12). If the direction is

not correct check the Reverse option in the dialog box.
7. Select the plane to restrain as the Z axis (

in Fig 8-12).

The Y axis is defined automatically. Suppose that the coordinate system is Left-handed
as shown in Fig 8-12. This may not be your case.
8. Press the OK button in the dialog box and hide the first coordinate system.
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Fig 8-12 Creating Coordinate System
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Now, let’s define the User-defined Restraint.

1. Double click on Finite Element Model.1 in the Spec Tree to invoke the GSA workbench.
2. Show Links Manager.1.
3. Choose User-defined Restraint from the Restraints toolbar.
4. Select the plane

A

which is 45 deg inclined.

A

Fig 8-13 Applying Symmetry Restraint
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5. Change the Type of Axis System to User in the dialog box and pick Current axis
selection area.
6. Select the coordinate system that is created in Fig 8-12.
The error message shown in Fig 8-14 appears because the reference coordinate system is
not right-handed. Therefore, we have to revert any of the three axes. Close the message.

Fig 8-14 Error Message
Let’s revert the Z axis of the coordinate system.
1. Expand Links Manager.1 and double click on Axis.5 so the Part Design workbench is
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invoked. The suffix number may be different.

2. Double click on Axis.5 once again in the Spec Tree. The Axis Definition dialog box
will appear.

3. Check the Reverse option next to the Z axis selection area.
4. Make sure that the coordinate system is Right-handed as in Fig 8-15 and press OK.
Now, we can proceed with defining User-defined Restraint as shown in Fig 8-16.

Fig 8-15 Modifying the Z axis
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The X, Y and Z axes of the Axis System are recognized as R, θ and Z in the cylindrical
coordinate system and each can be restrained using Translation 1, 2 and 3. The rotational
degree of freedom of the cylindrical coordinate system can be restrained with Rotation 1,
2 and 3 in the dialog box.
When we define mesh on a three dimensional body, we use the 3D tetrahedron element.
Note that the 3D element does not have rotational degree of freedom. Therefore, we do
not need to restrain Rotation 1, 2 and 3 in the dialog box. Whether you restrain the rotational degree of freedom of the 3D element or not, the result will not be affected.
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Fig 8-16 Applying User-defined Restraint

Apply Load
1. Choose the Rotation Force button from the Loads toolbar.
2. Select PartBody as the Support.
3. Select Z axis as the Rotation Axis.
4. Type in 5000 turn_mn as Angular Velocity and press OK.

Fig 8-17 Applying Rotation Force
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Resolve Singularity
We did not restrain the Z translational degree of freedom. Therefore, rigid body motion
may take place. Let’s restrain an arbitrary point in the Z direction.
1. Choose the User-defined Restraint button from the Restraints toolbar.
2. Select the vertex

A

as shown in Fig 8-18.

3. Restrain the Z Translation with regard to the Global coordinate system as shown in Fig
8-18.

A
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Fig 8-18 Restraining Z Translation

Check the FE Model
We have to check the FE model to see if the basic requirements were defined successfully.
1. Choose the Model Checker button from the Model Manager toolbar.
2. Look at the Status column from the Model Checker dialog box. We have not defined
the material yet.

Fig 8-19 Model Check
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Define Material
Let’s define the material for the part.
1. Expand Links Manager.1 and double click on the name of Product (flywheel_1_8).
The Part Design workbench will be invoked.
2. Press the Apply Material button. The Material Library dialog box will appear.
3. Select the Metal tab and select Aluminum. The OK button is not activated yet.
4. Select PartBody in the Spec Tree and press OK in the dialog box.
5. Double click on Finite Element Model.1 in the Spec Tree. The GSA workbench will
be invoked.
6. Save the file in d:\catia_cae. The name of the analysis file would be flywheel_1_8.
CATAnalysis. Note that the part file is saved at the same time.
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Fig 8-20 Material Library
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8.5 Solving
Run solver according to the following procedure.
1. Choose the Compute button from the toolbar.
2. Set the option to All and press OK in the dialog box.
The warnings dialog box appears because we applied Surface Sliding restraint on the
symmetric plane. The Surface Sliding restraint restrains rotational degrees of freedom to
make sure that normal displacement does not take place. However, there are no rotational
degrees of freedom in the 3D element. There is only one message in the dialog box because we applied User-defined Restraint for the other symmetric plane.
3. Close the warning message.
4. Resources required for the calculation are displayed in the dialog box. If all the estima-
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tions are zero or if the software cannot calculate the estimation, it means that you cannot
obtain the results. Press Yes and proceed with the solution process.

Fig 8-21 Executing Solver
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8.6 Post Processing
Fig 8-22 shows Von Mises Stress (Average iso) of the 1/8 model. View mode is Shading
with Material. Save the analysis file.

Fig 8-22 Von Mises Stress
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8.7 Analyzing the Full Model

Let’s perform the same analysis with the full model and compare the results.

Create FE Model
1. Open flywheel_full.CATPart.
2. Apply the material Aluminum to the PartBody.

Fig 8-23 Full Model
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3. Execute the GSA workbench.
4. Select Static Analysis in the New Analysis Case dialog box and press OK.

Fig 8-24 Analysis Case
5. Modify the mesh option as shown in Fig 8-25 and visualize the mesh. The mesh size is
the same as that of the 1/8 model. Therefore a much larger number of elements is generated. We can expect that the calculation time will take much longer.
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Fig 8-25 Modifying Mesh Option

Restraint and Load
Let’s apply load.
Boundary conditions and loads can be applied on 3D geometry such as faces, edges,
points and vertices, and the mesh has to be defined on the geometry.
1. Show Links Manager.1 in the Spec Tree.
2. Choose the Rotation Force button from the Loads toolbar.
3. Select PartBody as the Support.
4. Select the Z axis as the Rotation Axis.
5. Type in 5000 turn_mn as Angular Velocity and press OK.
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Fig 8-26 Applying Rotation Force
Now, let’s think about the restraint.
We have to restrain R, θ and Z translation with regard to the cylindrical coordinate system.
Whether you restrain the rotational degree of freedom of a 3D element or not, the result is
not affected because there are 3D elements defined.
Let’s create a virtual part on the cylindrical surface.
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1. Hide Mesh.1 in the Spec Tree.

2. Expand Links Manager.1 and hide all planes for convenience.

3. Choose the Smooth Virtual Part button from the Virtual Parts toolbar.
4. Select the cylindrical surface

A

as the Supports and press OK in the dialog box. If you

do not select an object for Handler, it is defined at the center of the support.

A

Fig 8-27 Creating a Virtual Part
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Now, let’s create User-defined Restraint.
1. Choose the User-defined Restraint button from the Restraints toolbar.
2. Select Virtual Part as the Supports. Be careful not to select the cylindrical face.
3. Set the Axis Type to User.
4. Pick the selection area of Current axis and select the axis system at the center. The
suffix number may be different.
5. Choose Cylindrical from the Local orientation dropdown list.
6. Check each option box to restrain translational degrees of freedom and press OK.
7. Save the file in d:\catia_cae. The name of the analysis file would be flywheel_full.
CATAnalysis. Note that the part file is saved at the same time.
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Fig 8-28 Applying User-defined Restraint

Solving
1. Choose the Compute button from the toolbar.
2. Set the option to All and press OK in the dialog box.
3. Resources required for the calculation are displayed in the dialog box. If all the estimations are zero or if the software cannot calculate the estimation, it means that you cannot
obtain the results. Press Yes and proceed with the solution process.
Calculation time takes longer because the number of elements is much higher than when
using the 1/8 model.
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Fig 8-29 Executing Solver

Post Processing
Fig 8-30 shows Von Mises Stress (Average iso) of the full model. View mode is Shading
with Material. Save the analysis file.
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Fig 8-30 Von Mises Stress
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8.8 Evaluation of the Results
The results of the full model and the 1/8 model are the same as each other. However, the
amount of resources required to solve the full model is much more than the difference of
the number of elements. Note that CPU time increases exponentially.
Full Model

1/8 Model

CPU Time

200 Sec

7 Sec

Memory

2.42 e5 kB

2.31 e4 kB

Disk

1.8 e6 kB

1.66 e5 kB
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